[Linux-Xtensa] Xtensa U-Boot ETHADDR fix

linux-xtensa at linux-xtensa.org linux-xtensa at linux-xtensa.org
Fri Aug 1 15:32:26 PDT 2008


Justin Waters wrote:
> Hello all,
> 
> I tested the new version of U-Boot, and it looks like everything is
> working great, with the exception of the Ethernet device.  It does not
> pick up it's MAC address from the environment, and just defaults to all
> zeros.  This causes the net commands to fail, stating that 'ethaddr'
> hasn't been set, which is obviously not true.
> 
> I tracked down the problem, and it seems to lie in the open_eth driver.
> I've attached a patch that fixes the issue by setting the proper
> variable to the value of 'ethaddr'.

This is strange given many people here have tested U-Boot networking
and it has been working fine.  Do you have the latest code?

> Other than that, everything is working great!
> 
> Also, I noticed that I can't check out the git repository for u-boot. I
> type:
> 
> git clone git://git.linux-xtensa.org/u-boot/u-boot-xtensa.git

See http://wiki.linux-xtensa.org/index.php/Repository_Access
and try:

   git clone git://git.linux-xtensa.org/git/u-boot/u-boot-xtensa.git

Hopefully that works better.

-Marc


> and I get the following error:
> 
> fatal: The remote end hung up unexpectedly
> 
> I don't have any issues with the kernel repositories.  I'm guessing it's
> some sort of permissions issue between the kernel and u-boot subdirs.
> 
> Thanks,
> 
> Justin Waters
> Linux Engineer
> TimeSys Corporation
> 




More information about the linux-xtensa mailing list