[Linux-Xtensa] Error when building the kernel when using the latest 2012.11 buildroot version.

Marc Gauthier marc at tensilica.com
Sun Jan 13 10:33:02 PST 2013


Hi Vadim,

Are you using the same Xtensa core config overlay in both cases?  The ATOMCTL register appeared in RC-2009.0, so is processor-config dependent, your toolchain might not recognize it if not built properly.  Or, perhaps the issue relates to how the core config overlay is installed under buildroot.

-Marc



________________________________
From: linux-xtensa-bounces at linux-xtensa.org [mailto:linux-xtensa-bounces at linux-xtensa.org] On Behalf Of Vadim Malenboim
Sent: Saturday, January 12, 2013 21:18
To: linux-xtensa at linux-xtensa.org; buildroot
Subject: [Linux-Xtensa] Error when building the kernel when using the latest 2012.11 buildroot version.


When trying to build the 2.6.29<tel:2.6.29>-amp kernel with buildroot 2012.11 compiled toolchain I receive the following error
"Invalid register ATOMCTL for wsr instruction".

This error doesn't happens when using the 2012.11-rc11 buildroot toolchain.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.linux-xtensa.org/pipermail/linux-xtensa/attachments/20130113/72fff2d4/attachment.html


More information about the linux-xtensa mailing list