[Linux-Xtensa] [PATCH] gpio: xtensa: depend on HAVE_XTENSA_GPIO32

Baruch Siach baruch at tkos.co.il
Thu Jan 2 12:18:42 UTC 2014


Hi Linus,

On Thu, Jan 02, 2014 at 01:07:24PM +0100, Linus Walleij wrote:
> On Mon, Dec 16, 2013 at 8:05 AM, Baruch Siach <baruch at tkos.co.il> wrote:
> 
> > Prevent build failure when the selected variant does not support GPIO32.
> >
> > Signed-off-by: Baruch Siach <baruch at tkos.co.il>
> (...)
> 
> >  config XTENSA_VARIANT_FSF
> >         bool "fsf - default (not generic) configuration"
> >         select MMU
> > +       select HAVE_XTENSA_GPIO32
> 
> (...)
> > +config HAVE_XTENSA_GPIO32
> > +       bool
> > +
> >  config GPIO_XTENSA
> >         bool "Xtensa GPIO32 support"
> >         depends on XTENSA
> > +       depends on HAVE_XTENSA_GPIO32
> 
> This is just a tautology, you don't need a helper bool
> for this.
> 
> Instead just select GPIO_XTENSA from your affected
> platforms.

But then you force this driver on all users. Why not leave the option to 
disable this driver when the user needs direct access to this hardware, or 
just wants to remove unused code?

> The patch only needs to hit arch/arm/mach-xtensa/Kconfig.

baruch

-- 
     http://baruch.siach.name/blog/                  ~. .~   Tk Open Systems
=}------------------------------------------------ooO--U--Ooo------------{=
   - baruch at tkos.co.il - tel: +972.2.679.5364, http://www.tkos.co.il -


More information about the linux-xtensa mailing list